Arquivos do Blog

Hybrid: Unable to update Active Directory information for the source mailbox at the end of the move. Error: UpdateMovedMailboxPermanentException.

Olá pessoal,

Durante uma migração de Exchange Server 2003 para Exchange Online, utilizando o Hybrid Configuration Wizard (HCW) e posteriormente o “Move-Mailbox” entre o ambiente On-Premise e Online, me deparei com o seguinte “Warning”:

 

“Unable to update Active Directory information for the source mailbox at the end of the move. Error: UpdateMovedMailboxPermanentException.”

 

Este erro ocorre quando o Exchange Server não consegue converter o usuário migrado de Mailbox para MEU (Mail Enabled User). Para resolver este problema devemos fazer a conversão manualmente utilizando os procedimentos abaixo:

 

1 – Limpar os seguintes atributos do usuário no Active Directory:

homeMDB,homeMTA,msExchHomeServerName,msExchPoliciesExcluded

2 – Incluir os seguintes valores nos campos:

  • msExchRemoteRecipientType=”4″
  • msExchRecipientDisplayType=”-2147483642
  • msExchRecipientTypeDetails=”2147483648″
  • targetaddress: SMTP:alias@tenant.mail.onmicrosoft.com

 

3 – Pronto! Feito isso o usuário se tornará um Mail Enabled User e o roteamento de e-mails acontecerá normalmente!

 

Diogo Heringer

clip_image001

Anúncios

Hybrid Configuration: Re-Migrando as caixas postais após cancelar o Move-Request

 

 

 

 

Olá pessoal,

Quando iniciamos um New-RemoteMoveRequest, no cenário de Exchange Híbrido, esta solicitação é criada automaticamente no ambiente do Exchange Online e marca o Mailbox no Exchange On-Premise com o símbolo de “Mailbox Movida”, conforme figura abaixo:

 

image

 

Porém, quando cancelamos esta requisição por algum motivo, ao tentar fazer a migração deste usuário novamente, as opções de “New-MoveRequest” e “New-RemoteMoveRequest” não aparecem, devido ao status de Move da Mailbox, que para o Exchange esta com o Status de “Mailbox Movida”.

É importante notar que a Move-Request é criada na Floresta do Exchange Online, e não localmente.

Para re-migrar os usuários basta seguir os seguintes passos:

 

1 – Abrir o ADSIEdit.msc e navegar até a partição de “Default Naming Context”:

 

image

 

2 – Em “Propriedades” do usuário, alterar o valor msExchMailboxMoveStatus  para “Not Set”:

 

image

 

3 – Pronto! Agora basta ir até o Exchange e verificar que o objeto não se encontra mais com o ícone de “Mailbox Migrada”.

 

Até a próxima,

Diogo Heringer

clip_image001

Exchange Server 2013: “Couldn’t Find the Enterprise Organization container”

 

 

 

Olá pessoal,

Recentemente em um ambiente de laboratório criado para testes de Exchange 2013 tive que fazer a reinstalação do produto. Como não tinha tempo hábil para remover o Exchange 2013 de forma correta, fiz pelo método não recomendado que é a remoção através do ADSIEdit e a deleção das Mailbox padrões criados pelo Exchange Server 2013.

Ao tentar reinstalar o Exchange 2013 me deparei com o seguinte erro:

“Couldn’t Find the Enterprise Organization container”

 

Este erro ocorre devido a uma Container oculto que é criado no Active Directory que ainda faz referência a instalação antiga do Exchange Server 2013. Para solução do problema devemos remover o Container da seguinte forma:

 

1 – No Active Directory navegar até “Exibir > Recursos Avançados

Agora podemos visualizar o Container “Microsoft Exchange System Objects”.

 

2 – Remover o Container “Microsoft Exchange System Objects”

 

3 – Pronto!

 

Agora basta executar novamente o instalador do Exchange que terá sucesso na instalação!

 

Até a próxima,

Diogo Heringer

clip_image001

Exchange Online: Error: #550 5.4.6 RESOLVER.FWD.Loop; there is a forwarding loop configured in the directory

 

 

Após a migração de Mailbox através da Coexistência Simples, ao enviar mensagem para o Mailbox migrado a seguinte mensagem de erro era retornada:

 

Diagnostic information for administrators:
Generating server: empresa.onmicrosoft.com
fernando@empresa.com.br
#550 5.4.6 RESOLVER.FWD.Loop; there is a forwarding loop configured in the directory ##rfc822;pzm@empresa.com.br

 

Ao rodar o comando  “”Get-MailboxStatistics –Identity fernando@empresa.com.br” foi detectado no resultado que o campo “”ForwardAddress”” está fazendo o apontamento para o próprio e-mail (fernando@empresa.com.br), o que gera o Loop dos e-mails.

Ao tentar executar o comando para correção do erro, ele nos retorna novamente outro erro:

 

PS C:\Users0012> Set-Mailbox -Identity fernando@empresa.com.br -ForwardingAddress $null
Missing an argument for parameter ‘ForwardingAddress’. Specify a parameter of type
‘Microsoft.Exchange.Configuration.Tasks.RecipientIdParameter’ and try again.
    + CategoryInfo          : InvalidArgument: (:) [Set-Mailbox], ParameterBindingException
    + FullyQualifiedErrorId : MissingArgument,Set-Mailbox

 

Para corrigir este problema basta seguir os seguintes passos:

 

1 – Clicar com o botão direito em “Microsoft Exchange” e em seguida em “Add Exchange Forest”:

 

image

 

2 – Na tela que se abrirá preencher os dados da seguinte forma:

 

image

 

3 – Inserir as credenciais do Tenant e clicar em “Ok”:

 

image

 

4 – No Tenant adicionado vamos expandir “Recipient Configuration”, navegar até “Mailbox”:

 

image

 

5 – Clicar com o botão direito do mouse na Mailbox desejada e em seguida em “Properties”:

 

image

 

6 – Navegar até a guia “Mail Flow Settings > “Delivery Options” e clicar em “Properties”:

 

image

 

7 – Desmarcar a opção “Forward to”. Clicar em “Ok” nas duas janelas para concluir a configuração com sucesso:

 

image

 

8 – Pronto, agora basta enviar um e-mail de teste para o usuário e verificar se ele não irá retornar!

 

Até a próxima,

Diogo Heringer

clip_image001